Funkcje statystyczne w Excelu szybko odnajdą maksimum i minimum

Data: 12-08-2013 r.

Gdy w arkuszu Excela potrzebujemy zlokalizować wartości największe i najmniejsze, warto wykorzystać funkcje statystyczne. Oprócz podstawowych funkcji MAX i MIN możemy zastosować inne, znacznie ułatwiające analizy zestawień liczbowych.

Przyjmijmy, że naszym zadaniem jest sprawdzenie, jaki udział mają dwie najlepsze i najgorsze transakcje w ogólnej wartości sprzedaży. Można to zadanie wykonać na piechotę, czyli posortować dane, wybrać 2 największe i najmniejsze wartości, podsumować jedne i drugie, a następnie podzielić przez ogólną sumę sprzedaży, tylko po co? Można to szybko zrobić za pomocą dwóch elastycznych formuł.

Rys. 1. Tabela transakcji

Aby sprawdzić, jaki jest udział dwóch największych wartości w całkowitej sprzedaży:
  • W dowolnej pustej komórce arkusza wprowadzamy następującą formułę: =SUMA(MAX.K(B2:B14;1);MAX.K(B2:B14;2))/SUMA(B2:B14)
  • Uzyskanej wartości nadajemy format procentowy, wybierając odpowiednią ikonę na pasku narzędziowym.

Teraz nadszedł czas wykonać to samo obliczenie, ale na wartościach najmniejszych. => W tym celu:
  • Wprowadzamy poniższą formułę: =SUMA(MIN.K(B2:B14;1); MIN.K(B2:B14;2))/SUMA(B2:B14)
  • Otrzymanemu ułamkowi nadajemy format procentowy.


Rys. 2. Otrzymane wyniki

Funkcja MIN.K i jej odpowiednik MAX.K wyznaczają pierwszą i drugą najmniejszą lub największą wartość w zakresie B2:B14 (zwróćmy uwagę na drugi argument tych funkcji). Pierwsza funkcja SUMA ma za zadanie dodanie tych skrajnych wartości. Gdy podzielimy ją przez ogólną sumę sprzedaży, otrzymamy poszukiwany udział.

Zaloguj się, aby dodać komentarz

Nie masz konta? Zarejestruj się »

Zobacz także

Jak zatrzeć ślady po przeglądaniu Internetu?

pobierz

Biznesplan

pobierz

Wzór Polityki Bezpieczeństwa w ochronie danych osobowych

pobierz

Konfiguracja bezpieczeństwa. Windows 10

pobierz

Polecane artykuły

Polecamy kancelarię:

Array ( [docId] => 34275 )
Array ( [docId] => 34275 )

Array ( [docId] => 34275 )