Suma czasu pracy w określonym dniu

Data: 06-02-2014 r.

W arkuszu znajdują się wartości czasu pracy dotyczące określonej maszyny. Chcesz teraz szybko sprawdzić, jaki jest łączny czas pracy w określone dni tygodnia, np. w środy. Konieczne jest zatem zbudowanie formuł, które najpierw wyznaczą numer dnia tygodnia, a następnie podsumują czasy, które dotyczą jedynie dat środowych.

Rejestr czasu pracy



Wyznaczenie numerów dni tygodnia

W tym celu:

  • W pierwszej kolejności wstaw pustą kolumnę pomiędzy kolumnami A i B. Obliczysz w niej numery kolejnych dni tygodnia, które będą potrzebne do dalszych obliczeń. Zaznacz całą kolumnę B, klikając jej nagłówek z oznaczeniem literowym i wciśnij kombinację klawiszy Ctrl + Shift + = (znak równości).
  • Do komórki B4 wprowadź następującą formułę:
    =DZIEŃ.TYG(A4;2)
    a następnie skopiuj poniżej.

Wskazówka

Jeśli w kolumnie B zamiast liczb pojawiły się daty, zaznacz je i wciśnij kombinację klawiszy Ctrl + Shift + ~ (tylda nad klawiszem Tab).

Wyjaśnienie działania formuły:

Formuła zwraca w wyniku liczbę reprezentującą numer kolejnego dnia tygodnia. Przy wprowadzonym argumencie 2 wyniki przedstawiają następująco: 1 – poniedziałek, 2 – wtorek, itd.

Numery dni tygodnia zostały wyznaczone

Łączny czas pracy

Możesz już przystąpić do obliczenia łącznego czasu pracy urządzenia w danym dniu tygodnia.

  • W dowolnej pustej komórce arkusza wprowadź następującą formułę:
    =SUMA.JEŻELI(B4:B33;3;C4:C33)

Funkcja przeszukuje zakres kolumny pomocniczej (w przykładzie B4:B33) pod kątem wystąpienia środy - czyli wartości 3 - i w przypadku znalezienia jej sumuje odpowiednią wartość z czasem pracy (zakres C4:C33).

Formatowanie

Obliczona wartość z pewnością niewiele Ci mówi, więc musisz nadać jej właściwe formatowanie.

Aby to zrobić:

  • Kliknij komórkę z wynikiem i korzystając ze skrótu klawiaturowego Ctrl + 1, uruchom okno dialogowe formatowania komórek.
  • W zakładce Liczby wybierz kategorię Niestandardowe, wprowadź typ:
    [g]:mm:ss
    i zatwierdź, klikając OK.

W ten prosty sposób obliczony został łączny czas pracy urządzenia w środy.

Łączny czas pracy w dany dzień tygodnia


Pamiętaj, aby przedstawiony format niestandardowy stosować zawsze wtedy, gdy wynik obliczeń na wartościach czasu przekracza 24 godziny.

Piotr Gromulski


Zobacz także:


Tagi: excel

Zaloguj się, aby dodać komentarz

Nie masz konta? Zarejestruj się »

Zobacz także

Jak zatrzeć ślady po przeglądaniu Internetu?

pobierz

Biznesplan

pobierz

Wzór Polityki Bezpieczeństwa w ochronie danych osobowych

pobierz

Konfiguracja bezpieczeństwa. Windows 10

pobierz

Polecane artykuły

Polecamy kancelarię:

Array ( [docId] => 34370 )
Array ( [docId] => 34370 )

Array ( [docId] => 34370 )