Excel: Numeracja porządkowa uwzględniająca niewypełnione wiersze

Autor: Gromulski Piotr
Data: 11-04-2012 r.

W arkuszu znajduje się zestawienie transakcji. Niestety pojawia się problem. Musisz ponumerować poszczególne pozycje, a na liście jest mnóstwo pustych wierszy. W jaki sposób to zrobić bez konieczności ręcznego usuwania niewypełnionych zakresów? Rozwiązaniem jest sprytna formuła.

Aby nadać jej poprawną numerację:

W pierwszej kolejności wstaw pustą kolumną po lewej. W tym celu kliknij nagłówek kolumny A, aby ją całą zaznaczyć i wciśnij kombinację klawiszy Ctrl + Shift + = (znak równości).

Do komórki A2 wprowadź następującą formułę:

=JEŻELI(B2<>"";ILE.NIEPUSTYCH($B$2:B2);"")

Skopiuj ją do komórek.

Wyjaśnienie działania formuły

W pierwszym argumencie funkcji JEŻELI sprawdzane jest, czy komórka B2 nie jest pusta. Jeśli nie jest pusta, wówczas wykonywana jest funkcja zawarta w drugim argumencie. W przeciwnym razie zwracany jest pusty ciąg znaków. W drugim argumencie funkcji JEŻELI zastosowano funkcję ILE.NIEPUSTYCH, która zwraca liczbę wypełnionych komórek w określonym zakresie. Zauważ, że dzięki odpowiedniemu adresowaniu ($B$2:B2), w miarę kopiowania w dół rozszerza się zakres działania funkcji. Np. w komórce A6 funkcja ILE.NIEPUSTYCH będzie operować już na zakresie B2:B6. Cała numeracja wprowadzana za pomocą formuły opiera się zatem na zliczaniu wypełnionych komórek ze stale rozszerzającego się zakresu.

Opinie czytelników

Dodawanie komentarzy tylko dla zalogowanych użytkowników

Polecane artykuły

Zobacz także

Statystyczna karta wypadków – wzór dokumentu

pobierz

Protokół powypadkowy – wzór dokumentu

pobierz

Rejestr wypadków przy pracy – wzór dokumentu

pobierz

Informacje świadka wypadku przy pracy – wzór dokumentu

pobierz

Polecamy

1323