Wychwytywanie błędów w obliczeniach w Excelu za pomocą funkcji JEŻELI

Data: 24-10-2013 r.

Przy budowaniu formuł może się zdarzyć, że podamy niedokładne odwołanie do komórek. Gdy część z nich nie będzie uwzględniona w obliczeniu, to otrzymamy zaniżone wyniki. Funkcja JEŻELI pomoże nam unikać takich sytuacji.

Przyjmijmy, że pracujemy przy zestawieniach z podsumowaniami wprowadzonymi zarówno po stronie wierszy, jak i kolumn. Niestety, w tego typu obliczeniach zdarzają się błędy, wynikające z tego, że formuła nie obejmuje wszystkich komórek z liczbami. Sprawdźmy, w jaki sposób wychwycić tego typu nieprawidłowości.

Przykład rocznego zestawienia sprzedaży z formułami podsumowującymi

Jednym z prostszych sposobów jest zastosowanie formuły porównującej sumę po stronie wierszy z sumą po stronie kolumn. Taka formuła może wyświetlać informację o błędach w przypadku, gdy sumy nie są równe.

1. Wpisujemy do komórki G14 formułę:

=JEŻELI(MODUŁ.LICZBY(SUMA(G2:G13)

W programie Excel obliczenia mogą być niedokładne ze względu na sposób przechowywania liczb ułamkowych w pamięci komputera. Dokładności te dotyczą wprawdzie 14. cyfry w liczbie, ale mogą wpływać na to, że sumy formuł podsumowujących nie będą sobie równe. Aby uniknąć takiej sytuacji, w przedstawionej formule wartość bezwzględną z różnicy sum przyrównujemy do wartości 0,001 i przyjmujemy, że mniejsza różnica jest wynikiem błędów dokładności przeliczeń w programie Excel.

W przypadku, gdy będzie występowała istotna różnica pomiędzy sumami, to w komórce G14 wyświetli się informacja o błędzie formuł. W przeciwnym razie w tej komórce nic nie zostanie wpisane. Jeśli chcemy podkreślić komunikat błędu, to zmieniamy kolor czcionki w tej komórce na czerwony.

Formuła w komórce D14 jest błędna i dlatego w komórce G14 wyświetla się informacja o błędzie


Zaloguj się, aby dodać komentarz

Nie masz konta? Zarejestruj się »

Zobacz także

Jak zatrzeć ślady po przeglądaniu Internetu?

pobierz

Biznesplan

pobierz

Wzór Polityki Bezpieczeństwa w ochronie danych osobowych

pobierz

Konfiguracja bezpieczeństwa. Windows 10

pobierz

Polecane artykuły

Polecamy kancelarię:

Array ( [docId] => 34302 )
Array ( [docId] => 34302 )

Array ( [docId] => 34302 )