Wyliczenie różnicy czasu w excelu

Data: 07-02-2014 r.

Potrzebujesz przeprowadzić analizę czasu pracy maszyn produkcyjnych. Pierwszym etapem jest porównanie rzeczywiście przepracowanych godzin z czasem nominalnym. W kolumnie wynikowej zastosowałeś więc zwykłą różnicę, ale niestety w niektórych komórkach Excel wyświetlił dziwne znaki. Jak sobie z tym poradzić?



Problem z odejmowaniem czasów w Excelu


Jeśli najedziesz wskaźnikiem myszy nad komórkę, w której wynik nie został zwrócony, zobaczysz komunikat: Daty lub czasy ujemne są wyświetlane jako # # # #.

W związku z występowaniem tego problemu powinieneś zastosować odpowiednią formułę, żeby poprawnie obliczyć i wyświetlić wynik.

W tym celu:

  • Formułę z komórki D2 zastąp poniższą:
    =JEŻELI(C2>B2;TEKST(C2-B2;"- gg:mm");B2-C2)
  • Skopiuj ją poniżej.

Wyjaśnienie działania formuły:

Za pomocą funkcji JEŻELI sprawdzasz, czy wartości czasu z kolumny C są większe od czasów z kolumny B. Jeśli tak, to z wykorzystaniem funkcji TEKST obliczana jest odwrócona różnica wartości (C2-B2), przy czym jej właściwy znak nadawany jest poprzez zastosowanie formatowania. W przypadku, gdy wartość z kolumny C nie jest większa od wartości z kolumny B, obliczana jest zwykła różnica: B2-C2.

Ujemne czasy zostały wyświetlone


Zauważ, że czasy ujemne zostały wyrównane do lewej strony wewnątrz komórki. Wynika to z faktu, że ujemne wartości nie są zwykłymi czasami. Zostały one obliczone przez funkcję TEKST i są traktowane przez Excela jako tekst. W związku z tym, że nie są to liczby, dalsze obliczenia na tych wartościach nie będą możliwe.

Piotr Gromulski



Zobacz także:


Tagi: excel

Zaloguj się, aby dodać komentarz

Nie masz konta? Zarejestruj się »

Zobacz także

Jak zatrzeć ślady po przeglądaniu Internetu?

pobierz

Wzór Polityki Bezpieczeństwa w ochronie danych osobowych

pobierz

Konfiguracja bezpieczeństwa. Windows 10

pobierz

10 sprytnych trików na szybkie obliczenia w Excelu

pobierz

Polecane artykuły

Array ( [docId] => 34372 )
Array ( [docId] => 34372 )

Array ( [docId] => 34372 )