Zastosowania funkcji LICZ.JEŻELI

Autor: Marcin Sarna
Data: 11-02-2015 r.

Sumowanie to jedna z podstawowych operacji arytmetycznych. Nie zawsze jednak chcemy zliczyć wszystkie komórki w podanym zakresie, a tylko niektóre z nich. Funkcja LICZ.JEŻELI pozwala zliczenie komórek spełniających określone warunki.

Funkcja LICZ.JEŻELI przydaje się, jeśli musimy policzyć sumę komórek, które spełniają określony warunek (jeden). Na przykład z zakresu A1:A10 chcemy policzyć tylko komórki o wartości większej niż 50.

Jeżeli potrzebujemy określić dwa lub więcej warunków (np. zliczając komórki o wartości większej niż 50 i mniejszej niż 100), posłużymy się funkcją LICZ.WARUNKI, a w Excelach starszych niż 2007 – funkcją SUMA.ILOCZYNÓW.

Składnia funkcji LICZ.JEŻELI

Załóżmy, że mamy taką tabelę jak na rysunku.

Rysunek 1. Przykładowe dane przedstawiające zarobki brutto poszczególnych pracowników

Jeżeli chcemy teraz zliczyć komórki z zakresu B2:B7, które zawierają tylko wynagrodzenia wyższe niż 4000 złotych, powinniśmy użyć formuły =LICZ.JEŻELI(B2:B7;”>4000”). Dlaczego tak?

Składnia funkcji LICZ.JEŻELI jest następująca: =LICZ.JEŻELI(zakres;kryteria). W zakres wskazujemy, jakie komórki mają być brane pod uwagę, a w kryteria dodatkowe warunki, jakie muszą one spełniać, aby zostać zsumowane.

Jeżeli zaś chcielibyśmy zsumować komórki według różnych kryteriów dla różnych z tych komórek, trzeba skorzystać z LICZ.WARUNKI. Składnia wygląda tak: =LICZ.WARUNKI(zakres1;kryteria1;zakres2;kryteria2;zakres3;kryteria3;...).

Czyli zakres1 zostanie przeszukany pod kątem spełniania tylko kryteria1. Każda komórka z zakres1 spełniająca kryteria1 zostanie zsumowana, podobnie stanie się w odniesieniu do komórek z dalszych wskazanych zakresów.

Określenie kryteriów

Przede wszystkim możemy odwoływać się do innych komórek w kryteriach. Przykładowo, =LICZ.JEŻELI(B2:B7;C2) zsumuje tylko te komórki, które mają wartość taką samą jak komórka C2.

W kryteriach nie ma znaczenia wielkość znaków (PENSJA oraz pensja znaczy to samo). Możemy się natomiast posługiwać tzw. znakami wieloznacznymi:

  • pytajnik (?) – zastępuje jeden dowolny znak;

  • gwiazdka (*) – zastępuje dowolną ilość znaków.

Na przykład =LICZ.JEŻELI(A1:A7;”*ski”) wskaże na liczbę pracowników z końcówką nazwiska ski. Możemy także policzyć, ile komórek z listy w ogóle ma wpisaną jakąkolwiek wartość (nie jest pusta): =LICZ.JEŻELI(B2:B7;”*”). Z kolei niepuste komórki policzymy tak: =LICZ.JEŻELI(B2:B7;”<>”&”*”).

Jeżeli chcemy wyszukać autentyczny pytajnik lub gwiazdkę, musimy je poprzedzić znakiem ~ (tylda). Na przykład =LICZ.JEŻELI(B2:B7;”Znak ~* oznacza*”) weźmie pod uwagę wszystkie komórki o wartości rozpoczynającej się od Znak * oznacza, niezależnie od tego, co znajdzie się dalej.

Rysunek 2. Przykłady z artykułu: po lewej stronie formuła, po prawej jej wynik

Przykłady funkcji LICZ.JEŻELI

Formuła =LICZ.JEŻELI(B2:B7;"<=4000") znajdzie nam sumę wynagrodzeń mniejszych lub równych 4000 złotych. Z kolei druga z poznanych przez nas funkcji =LICZ.WARUNKI(B2:B7;">=3000";B2:B7;"<=5000") weźmie pod uwagę tylko wynagrodzenia z przedziału od 3000 do 5000 złotych.

A co z datami? Daty można „liczyć” podobnie jak liczby, przy czym data późniejsza jest uznawana za „większą” niż wcześniejsza.

Rysunek 3. Przykładowe daty w komórkach A1:A4

I tak:

  • =LICZ.JEŻELI(A1:A4;">2012-12-02") – policzy ilość dat, które są późniejsze niż 2 lutego 2012 roku;

  • =LICZ.JEŻELI(A1:A4;"2009-09-24") – wskaże, ile razy w komórkach A1:A4 występuje data 24 września 2009 roku;

  • =LICZ.WARUNKI(A1:A4;">=2011-06-01";A1:A4;"<=2013-10-01") – zliczy, ile razy w zakresie A1:A4 pojawia się data późniejsza lub równa 1 czerwca 2011 roku oraz wcześniejsza niż 1 października 2013 roku.

Rysunek 4. Formuły i ich rezultaty

Marcin Sarna

Zaloguj się, aby dodać komentarz

Nie masz konta? Zarejestruj się »

Zobacz także

Jak zatrzeć ślady po przeglądaniu Internetu?

pobierz

Biznesplan

pobierz

Wzór Polityki Bezpieczeństwa w ochronie danych osobowych

pobierz

Konfiguracja bezpieczeństwa. Windows 10

pobierz

Polecane artykuły

Polecamy kancelarię:

  • Kancelaria Prawna Iurisco Edyta Przybyłek

    ul. Zgrzebnioka 28, 40-520 Katowice

    Wyświetl wizytówkę
  • Kancelaria Radcy Prawnego Marcin Majcherczyk

    ul. Stawowa 4 lok. 39, 41-200 Sosnowiec

    Wyświetl wizytówkę
  • THE N.E.W.S. LAW CENTER Kancelaria Adwokatów i Radców Prawnych

    ul. Kazachska 1/89, 02-999 Warszawa

    Wyświetl wizytówkę
  • adwokat Wojciech Rudzki - kancelaria adwokacka

    Józefa Piłsudskiego 40/4 Kraków 31 - 111

    Wyświetl wizytówkę
  • Kancelaria Radcy Prawnego Robert Dudkowiak

    ul. Jana Pawła II 11 lok. 5, 62-300 Września

    Wyświetl wizytówkę
  • Kancelaria Adwokacka Adwokata Piotra Sęka

    ul. Narutowicza 44 lok. 20, 90-135 Łódź

    Wyświetl wizytówkę
  • Kancelaria Radców Prawnych ARVE M.Kusztan & R.Ponichtera Sp. K.

    ul. Czysta 4, 50-013 Wrocław

    Wyświetl wizytówkę
  • Kancelaria Radcy Prawnego Marek Foryś

    ul. Słupecka 9/1, Gdynia

    Wyświetl wizytówkę
  • Kancelaria MERITUM

    ulica Westerplatte 13/5, 31-033 Kraków

    Wyświetl wizytówkę
  • Kancelaria Radcy Prawnego Radosław Tymiński

    Łukowska 9 Lok. 126, 04-133 Warszawa

    Wyświetl wizytówkę
Array ( [docId] => 36546 )
Array ( [docId] => 36546 )

Array ( [docId] => 36546 )