Makro uruchamiane w zależności od wpisu w komórce

Autor: Piotr Dynia
Data: 26-05-2015 r.

Sposobów na uruchamianie makr w Excelu jest bez liku. Można to zrobić za pomocą przycisku wstawionego do arkusza, poprzez okno dialogowe Makra lub uzależnić uruchomienie procedury od akcji wykonanej w arkuszu lub w skoroszycie. W tym triku pokażemy pewną interesującą kombinację, która na pewno okaże się pomocna w pracy. Kod Visual Basic będzie uruchamiany tylko wówczas, gdy w określonej komórce pojawi się dany tekst.

Aby taki efekt uzyskać:

  1. Otwórzmy Edytor Visual Basic za pomocą kombinacji klawiszy lewy [Alt]+[F11].

  2. Z menu Insert wybierzmy polecenie Module.

  3. Wpiszmy poniższy kod.

  4. Zapiszmy i zamknijmy Edytor VBA.

Sub MojeMakro()

MsgBox "Jestem Twoim makrem."

End Sub

Public Function UruchomMojeMakro() As String

MojeMakro

UruchomMojeMakro = "Moje makro zostało uruchomione."

End Function

Makro ma nazwę MojeMakro, natomiast do jego uruchamiania utworzyliśmy dodatkową funkcję użytkownika o nazwie Uruchom MojeMakro. Można z niej korzystać, jak z normalnej funkcji arkuszowej. Przyjmijmy, że makro MojeMakro ma zostać uruchomione tylko wówczas, gdy w komórce A1 pojawi się tekst Start. Aby taki efekt uzyskać:

  1. Do dowolnej pustej komórki arkusza wpiszmy następującą formułę:

=JEŻELI(A1=”Start”;UruchomMojeMakro();”Podajmy słowo uruchamiające”)

  1. Teraz wpiszmy do komórki A1 tekst Start i wciśnijmy klawisz [Enter].

Uzyskamy efekt jak na rysunku 1.

Rysunek 1. Wartość w komórce A1 uruchomiła makro

Po kliknięciu przycisku OK w komórce pojawi się komunikat: Moje makro zostało uruchomione.

Piotr Dynia

Zaloguj się, aby dodać komentarz

Nie masz konta? Zarejestruj się »

Zobacz także

Jak zatrzeć ślady po przeglądaniu Internetu?

pobierz

Biznesplan

pobierz

Wzór Polityki Bezpieczeństwa w ochronie danych osobowych

pobierz

Konfiguracja bezpieczeństwa. Windows 10

pobierz

Polecane artykuły

Polecamy kancelarię:

  • Kancelaria Adwokacka Adwokata Piotra Sęka

    ul. Narutowicza 44 lok. 20, 90-135 Łódź

    Wyświetl wizytówkę
  • Kancelaria Radców Prawnych ARVE M.Kusztan & R.Ponichtera Sp. K.

    ul. Czysta 4, 50-013 Wrocław

    Wyświetl wizytówkę
  • Kancelaria Radcy Prawnego Marek Foryś

    ul. Słupecka 9/1, Gdynia

    Wyświetl wizytówkę
  • Kancelaria MERITUM

    ulica Westerplatte 13/5, 31-033 Kraków

    Wyświetl wizytówkę
  • Kancelaria Radcy Prawnego Radosław Tymiński

    Łukowska 9 Lok. 126, 04-133 Warszawa

    Wyświetl wizytówkę
  • Kancelaria Prawna Iurisco Edyta Przybyłek

    ul. Zgrzebnioka 28, 40-520 Katowice

    Wyświetl wizytówkę
  • Kancelaria Radcy Prawnego Marcin Majcherczyk

    ul. Stawowa 4 lok. 39, 41-200 Sosnowiec

    Wyświetl wizytówkę
  • THE N.E.W.S. LAW CENTER Kancelaria Adwokatów i Radców Prawnych

    ul. Kazachska 1/89, 02-999 Warszawa

    Wyświetl wizytówkę
  • adwokat Wojciech Rudzki - kancelaria adwokacka

    Józefa Piłsudskiego 40/4 Kraków 31 - 111

    Wyświetl wizytówkę
  • Kancelaria Radcy Prawnego Robert Dudkowiak

    ul. Jana Pawła II 11 lok. 5, 62-300 Września

    Wyświetl wizytówkę
Array ( [docId] => 37269 )
Array ( [docId] => 37269 )

Array ( [docId] => 37269 )