Numeracja dopasowująca się do liczby wierszy tabeli

Data: 16-10-2013 r.

W pierwszej kolumnie tworzonych wykazów znajduje się najczęściej numeracja porządkowa wierszy. Jeżeli do tabeli dopisujemy kolejne pozycje, to musimy także pamiętać o ręcznym zwiększaniu numeracji. Okazuje się, że możemy nakłonić Excela, aby robił to za nas.

Na podstawie przykładu z rysunku 1 sprawdzimy, jak to zrobić za pomocą sprytnej formuły.

Pusty wykaz, w którym zastosujemy dynamiczną numerację


W tym celu:

  1. W komórce A2 wprowadzamy następującą formułę:
    =JEŻELI(CZY.PUSTA(B2);"";WIERSZ()-1)
  2. Kopiujemy ją w dół na dowolną liczbę komórek.
  3. Dopisujemy teraz kilka pozycji do swojego wykazu. Numeracja wierszy zostanie automatycznie nadana, jak to przedstawia rysunek.
Formuła działa znakomicie


Wyjaśnienie działania formuły:

W pierwszym argumencie funkcji JEŻELI sprawdzamy, czy komórka B2 jest pusta. Jeśli tak, wówczas zwracany jest pusty ciąg znaków (""). Jeżeli jest wypełniona (czyli czy dodano nową pozycję do wykazu), nadawana jest kolejna liczba porządkowa. Jest ona wyznaczana za pomocą funkcji WIERSZ. Jeśli nie posiada ona żadnego argumentu, wówczas zwraca numer wiersza, w którym aktualnie się znajduje. Od zwracanego przez nią wyniku należy odjąć jeszcze 1, aby wiersz nagłówkowy nie był uwzględniany przy wyznaczaniu kolejnego numeru porządkowego.

Wskazówka
Jeżeli chcemy, aby liczby porządkowe były wstawiane razem z kropką, nieznacznie rozbudujmy swoją formułę w komórce A2:
=JEŻELI(CZY.PUSTA(B2);"";WIERSZ()-1&".")


Tagi: excel

Zaloguj się, aby dodać komentarz

Nie masz konta? Zarejestruj się »

Zobacz także

Jak zatrzeć ślady po przeglądaniu Internetu?

pobierz

Biznesplan

pobierz

Wzór Polityki Bezpieczeństwa w ochronie danych osobowych

pobierz

Konfiguracja bezpieczeństwa. Windows 10

pobierz

Polecane artykuły

Polecamy kancelarię:

Array ( [docId] => 34290 )
Array ( [docId] => 34290 )

Array ( [docId] => 34290 )