Numeracja dopasowująca się do liczby wierszy tabeli

Data: 16-10-2013 r.

W pierwszej kolumnie tworzonych wykazów znajduje się najczęściej numeracja porządkowa wierszy. Jeżeli do tabeli dopisujemy kolejne pozycje, to musimy także pamiętać o ręcznym zwiększaniu numeracji. Okazuje się, że możemy nakłonić Excela, aby robił to za nas.

Na podstawie przykładu z rysunku 1 sprawdzimy, jak to zrobić za pomocą sprytnej formuły.

Pusty wykaz, w którym zastosujemy dynamiczną numerację


W tym celu:

  1. W komórce A2 wprowadzamy następującą formułę:
    =JEŻELI(CZY.PUSTA(B2);"";WIERSZ()-1)
  2. Kopiujemy ją w dół na dowolną liczbę komórek.
  3. Dopisujemy teraz kilka pozycji do swojego wykazu. Numeracja wierszy zostanie automatycznie nadana, jak to przedstawia rysunek.
Formuła działa znakomicie


Wyjaśnienie działania formuły:

W pierwszym argumencie funkcji JEŻELI sprawdzamy, czy komórka B2 jest pusta. Jeśli tak, wówczas zwracany jest pusty ciąg znaków (""). Jeżeli jest wypełniona (czyli czy dodano nową pozycję do wykazu), nadawana jest kolejna liczba porządkowa. Jest ona wyznaczana za pomocą funkcji WIERSZ. Jeśli nie posiada ona żadnego argumentu, wówczas zwraca numer wiersza, w którym aktualnie się znajduje. Od zwracanego przez nią wyniku należy odjąć jeszcze 1, aby wiersz nagłówkowy nie był uwzględniany przy wyznaczaniu kolejnego numeru porządkowego.

Wskazówka
Jeżeli chcemy, aby liczby porządkowe były wstawiane razem z kropką, nieznacznie rozbudujmy swoją formułę w komórce A2:
=JEŻELI(CZY.PUSTA(B2);"";WIERSZ()-1&".")


Tagi: excel

Zaloguj się, aby dodać komentarz

Nie masz konta? Zarejestruj się »

Zobacz także

Jak zatrzeć ślady po przeglądaniu Internetu?

pobierz

Biznesplan

pobierz

Wzór Polityki Bezpieczeństwa w ochronie danych osobowych

pobierz

Konfiguracja bezpieczeństwa. Windows 10

pobierz

Polecane artykuły

Polecamy kancelarię:

  • Kancelaria Prawna Iurisco Edyta Przybyłek

    ul. Zgrzebnioka 28, 40-520 Katowice

    Wyświetl wizytówkę
  • Kancelaria Radcy Prawnego Marcin Majcherczyk

    ul. Stawowa 4 lok. 39, 41-200 Sosnowiec

    Wyświetl wizytówkę
  • THE N.E.W.S. LAW CENTER Kancelaria Adwokatów i Radców Prawnych

    ul. Kazachska 1/89, 02-999 Warszawa

    Wyświetl wizytówkę
  • adwokat Wojciech Rudzki - kancelaria adwokacka

    Józefa Piłsudskiego 40/4 Kraków 31 - 111

    Wyświetl wizytówkę
  • Kancelaria Radcy Prawnego Robert Dudkowiak

    ul. Jana Pawła II 11 lok. 5, 62-300 Września

    Wyświetl wizytówkę
  • Kancelaria Adwokacka Adwokata Piotra Sęka

    ul. Narutowicza 44 lok. 20, 90-135 Łódź

    Wyświetl wizytówkę
  • Kancelaria Radców Prawnych ARVE M.Kusztan & R.Ponichtera Sp. K.

    ul. Czysta 4, 50-013 Wrocław

    Wyświetl wizytówkę
  • Kancelaria Radcy Prawnego Marek Foryś

    ul. Słupecka 9/1, Gdynia

    Wyświetl wizytówkę
  • Kancelaria MERITUM

    ulica Westerplatte 13/5, 31-033 Kraków

    Wyświetl wizytówkę
  • Kancelaria Radcy Prawnego Radosław Tymiński

    Łukowska 9 Lok. 126, 04-133 Warszawa

    Wyświetl wizytówkę
Array ( [docId] => 34290 )
Array ( [docId] => 34290 )

Array ( [docId] => 34290 )