Wyznaczenie daty następnego dnia roboczego

Autor: Piotr Dynia
Data: 26-05-2015 r.

Załóżmy, że mamy arkusz z terminami wysyłek. Chcemy, aby obok kolumny z terminem wysłania pojawiła się maksymalna data dostarczenia wysyłki, która jest równa dacie następnego dnia roboczego.

Rysunek 1. Tabela z terminami wysyłek

Aby rozwiązać to zadanie, można posłużyć się formułą opartą na funkcji JEŻELI.

W tym celu:

  1. W komórce D2 wpiszmy formułę:

=JEŻELI(DZIEŃ.TYG(B2;2)=5;B2+3;JEŻELI(DZIEŃ. TYG(B2;2)=6;B2+2;B2+1))

Formuła sprawdza, jaki jest dzień tygodnia w komórce B2. Jeśli funkcja DZIEŃ.TYG zwróci wartość 5 oznacza to, że w komórce B2 jest data oznaczająca piątek – wtedy formuła dodaje 3 dni do daty znajdującej się w komórce B2. Jeśli funkcja DZIEŃ.TYG zwróci wartość 6, to oznacza, że w komórce B2 jest sobota – wtedy formuła dodaje dwa dni do daty znajdującej się w komórce B2. W pozostałych przypadkach formuła dodaje tylko jeden dzień do daty znajdującej się w komórce B2.

  1. Jeśli w komórce pojawi się data, to przejdźmy do kroku 6. Jeśli pojawi się liczba, to zaznaczmy komórkę D2 i otwórzmy okno formatowania komórek.

Pamiętajmy, że data to też liczba – tylko odpowiednio sformatowana. Każda data to liczba dni, które upłynęły od 31 grudnia 1899 r. Można do daty dodawać i odejmować dni, jak do zwykłych liczb całkowitych.

  1. Przejdźmy do zakładki Liczby.

  2. Na liście Kategoria wybierzmy Data, a na liście Typ wybierzmy odpowiedni format daty.

  3. Naciśnijmy przycisk OK, aby zatwierdzić zmianę formatu liczbowego komórki.

  4. Zaznaczmy komórkę D2 i wybierzmy polecenie Kopiuj, aby skopiować komórkę.

  5. Zaznaczmy pozostałe komórki w kolumnie i wybierzmy polecenie Wklej, aby wkleić formuły do komórek.

Końcowy efekt zaprezentowany jest na rysunku 2.

Rysunek 2. Kolumna z datami następnego dnia roboczego

Piotr Dynia

Tagi: excel

Zaloguj się, aby dodać komentarz

Nie masz konta? Zarejestruj się »

Zobacz także

Jak zatrzeć ślady po przeglądaniu Internetu?

pobierz

Wzór Polityki Bezpieczeństwa w ochronie danych osobowych

pobierz

Konfiguracja bezpieczeństwa. Windows 10

pobierz

10 sprytnych trików na szybkie obliczenia w Excelu

pobierz

Polecane artykuły

Array ( [docId] => 37271 )
Array ( [docId] => 37271 )

Array ( [docId] => 37271 )